Brewbuilder RIMS issue

A forum for those who boldy recirculate where no man has. .... you know the rest
mosquat
Piss Artist
Posts: 228
Joined: Tue Feb 03, 2015 2:30 pm

Re: Brewbuilder RIMS issue

Post by mosquat » Thu Oct 22, 2015 12:19 pm

Yep I will agree too no doubt when I get testing proper. 3kw is for boiling wort

User avatar
Aleman
It's definitely Lock In Time
Posts: 6129
Joined: Sun Jun 03, 2007 11:56 am
Location: Mashing In Blackpool, Lancashire, UK

Re: Brewbuilder RIMS issue

Post by Aleman » Thu Oct 22, 2015 12:42 pm

orlando wrote:
Aleman wrote:Of course I still think 3KW in a well insulated system is too much for RIMS, I'd be happier with 1 or 1.5KW :D
Are you saying the "fix" in the PID software is still not good enough and therefore changing or controlling the element directly is a better answer?
I had no issues using a 3KW element in a RIMS configuration using an Auber PID, autotuned in the manner that I described (using the spent grain from a mash to auto tune). I certainly had no need to go back into the system after tuning and alter the values.

Having said that I could get temperature ramps of more than 3C per minute with the 3KW element in a 15Kg grain bill . . . I think that is pushing it, and either using a LWD element with a lower rating or using some sort of power control circuitry on the live feed after the PID (Burst Fire Rectifier, Phase Angle Controller) is another way to go. . . .Of course altering teh PID parameters is also another useful (and less costly) approach ;)

User avatar
Coffeeuk
Piss Artist
Posts: 287
Joined: Mon Apr 29, 2013 5:05 pm

Re: Brewbuilder RIMS issue

Post by Coffeeuk » Sat Oct 24, 2015 5:00 pm

mosquat wrote:good luck with that mate, will be interesting to see how it goes
All done, took 10 mins to fit

Image

Image


How did you get on with yours ? Did you get anywhere asking mark ?

mosquat
Piss Artist
Posts: 228
Joined: Tue Feb 03, 2015 2:30 pm

Re: Brewbuilder RIMS issue

Post by mosquat » Sat Oct 24, 2015 7:56 pm

Looks good mate, may need to get some tips off you if I try the same!

Yea I showed him this thread and he agreed it was a duff TC so will be sending a new one out, may give him a reminder nudge as I want to use the RIMS soon if i can

mosquat
Piss Artist
Posts: 228
Joined: Tue Feb 03, 2015 2:30 pm

Re: Brewbuilder RIMS issue

Post by mosquat » Thu Oct 29, 2015 11:17 am

Just to add some closure to this post....Mr Lard sent a new Triclamp female element fitting at no extra cost and didn't charge P@P either...this has solved my leak...now onto the problem of airlocks and pumps :roll:

User avatar
Coffeeuk
Piss Artist
Posts: 287
Joined: Mon Apr 29, 2013 5:05 pm

Re: Brewbuilder RIMS issue

Post by Coffeeuk » Thu Oct 29, 2015 12:55 pm

mosquat wrote:Just to add some closure to this post....Mr Lard sent a new Triclamp female element fitting at no extra cost and didn't charge P@P either...this has solved my leak...now onto the problem of airlocks and pumps :roll:
Excellent, I'm glad you got it sorted.

Post Reply